• WAP手机版 保存到桌面加入收藏设为首页
电脑教程

transmission 修改配置一直不出现密码验证登录

时间:2017-07-21 09:47:50   作者:哎丫丫整理   阅读:2594   评论:0

由于迅雷远程突然的倒闭,弄的我小编我措手不及啊!~

只好在我的centos上安装transmission,通过百度的教程,顺利的安装并运行transmission。

但是却一直无法V用用户和密码验证登录。

配置好    "rpc-authentication-required": true,

,在重启服务后,true会自动变为false。

这样就会自动变为无需认证可以直接使用远程访问的。

经过再次的百度,终于找到原因,

原来在etc/init.d/transmission-daemon 这个文件里面,默认调用了参数 -T

如:

TRANSMISSION_HOME=/var/lib/transmission


DAEMON_USER="transmission"

DAEMON_ARGS="-T --blocklist -g $TRANSMISSION_HOME/.config/transmission"


而在

 transmission-daemon -help

有帮助说明的
-t   --auth                             Require authentication

-T   --no-auth                          Don't require authentication

好了,只要把-T 改为小写的-t 在设置好配置文件,就可以正常的出现认证窗口咯

transmission_修改配置一直不出现密码验证登录

还补充下开机不自动启动的解决方法,

由于我的系统是设置为定时自动关机,然后定时路由器自动wol唤醒的。

今天早上即20170723,发现系统并没有自动运行transmission-daemon 。

也就是说etc/init.d/transmission-daemon 脚本没有自动启动。

简单点可以直接在etc/rc.local里面直接添加一句etc/init.d/transmission-daemon start

即可实现。

还有一个方法就是,系统已经注6transmission-daemon为服务咯,通过

chkconfig --list 可以看见服务,只不过是所有level都是off而已


transmission-daemon     0:off   1:off   2:off   3:off   4:off   5:off   6:off

设置一下 务自动运行

chkconfig --level 12345 transmission-daemon on

检查下
transmission-daemon     0:off   1:on    2:on    3:on    4:on    5:on    6:off

重新启动下centos 系统 Ok
   版权声明,所有转载都有注明出处,本站不负责承担任何法律责往。若有侵权,请联系我。我会及时删除。

电脑维护,系统安装,软 、硬件维修,电脑配件,零售业务,网站建设,路由器安装设置 服务器维护,电脑、网络维护,智能手机刷机,安装WIFI 调试!郴州网站建设 小程序搭建 郴州电脑维修

        咨询电话:18175576644  点击这里给我发消 息
   扫描二维码。关注公众号,小程序
       享受星级服务   

手机点击二维码关注
      


手机点击打开小程序
      


相关评论
免责申明:本站部分资料来源互联网,如果侵犯了您的版权,请作者速来电或QQ与本站联系,我们将第一时间给予以改正或删除。

Copyright © 2020 哎丫丫电脑 All Rights Reserved 
 工信部备案:湘ICP备14010293号-1

不想添加任何联系方式?点击我直接访客对话